Внешняя компонента для преобразования файлов из/в кодировку Base64 в 1С 7.7

Публикация № 1417135 Дата создания: 06.04.21 10:30

Разработка - Разработка внешних компонент

7.7 внешняя компонента кодировка Base64 dll преобразование файлов EncodeBase64 ЗакодироватьBase64 DecodeBase64 РаскодироватьBase64

Эта внешняя компонента Base64.dll предназначена для платформы 1С версии 7.7. Используется для преобразования файлов из/в кодировку Base64 из встроенного языка 1С Предприятие. Компонента тестировалась на базе конфигурации Бухгалтерский учет для Казахстана, редакции 7.70.257.

Для работы с компонентой положите файл Base64.dll, например в каталог базы данных. В конфигураторе используйте функцию ЗагрузитьВнешнююКомпоненту:

Процедура ПриОткрытии()
	Если ЗагрузитьВнешнююКомпоненту(КаталогИБ() + "Base64.dll")=0 Тогда
		Сообщить("Не удается загрузить Base64.dll!");
		Возврат;
	Иначе
		Сообщить("Удалось загрузить Base64.dll!");	
	КонецЕсли;
КонецПроцедуры	// ПриОткрытии

// Преобразует файл в Base64 строку
Функция Base64(ПутьКФайлу)
	Попытка
		ВК = СоздатьОбъект("AddIn.Base64");
	Исключение
		Сообщить("Не удается создать объект AddIn.Base64!");
		а=1/0;
	КонецПопытки;
	СтрокаИзФайла = ВК.ЗакодироватьBase64(ПутьКФайлу);
	Возврат СтрокаИзФайла;
КонецФункции	// Base64

С помощью этой компоненты можно кодировать данные файла в строку Base64. После чего сформировать POST-запрос с разделом filename, который указывает на раздел передачи файла и отправить эти данные на сервер. Если вам приходится работать с версией 7.7, то возможно вам пригодится отчёт по остаткам товаров со сравнением цен и выборкой по количеству.

 

Скачать файлы

Наименование Файл Версия Размер
Внешняя компонента для преобразования файлов из/в кодировку Base64 в 1С 7.7:

.dll 307,50Kb
1
.dll 1.1.0 307,50Kb 1 Скачать

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. user711367_denis 07.04.21 12:52 Сейчас в теме
Можно без компонент делать стандартными средствами винды:

Функция КодироватьФайл(ФайлИлиСтрокаИсточник, Кодировка="base64",ВозвращатьКакФайл=0) Экспорт
	ЦДО=СоздатьОбъект("CDO.Message");
	Файл=ФайлИлиСтрокаИсточник;
	Попытка
		Если ФС.СуществуетФайл(Файл)=1 Тогда
			Состояние("Кодирование данных..");
			Вложение=ЦДО.AddAttachment(Файл);
			Вложение.ContentTransferEncoding=Кодировка;
			Стрим=Вложение.GetEncodedContentStream();
		Иначе
			БодиПарт=ЦДО.BodyPart;
			Поля=БодиПарт.Fields;
			Поле=Поля.Item("urn:schemas:mailheader:content-type");
			Поле.Value="text/plain; charset=""windows-1251""";
			Поля.Update();
			Стрим = БодиПарт.GetDecodedContentStream();
			Стрим.charset = "windows-1251";
			Стрим.WriteText(Файл);
			Стрим.Flush();
			БодиПарт.ContentTransferEncoding = Кодировка;
			Стрим=БодиПарт.GetEncodedContentStream();
		КонецЕсли;
		
		Если ВозвращатьКакФайл=0 Тогда
			Возврат Стрим.ReadText();
		Иначе
			Стрим.SaveToFile(ВозвращатьКакФайл);
			Возврат ВозвращатьКакФайл;
		КонецЕсли;
	Исключение
		Сообщить("Ошибка кодирования в Base64: " + ОписаниеОшибки());
		Возврат 0
	КонецПопытки;	
КонецФункции
Показать
2. softmaker 27 07.04.21 15:19 Сейчас в теме
(1) Здорово, что есть такой вариант!
Оставьте свое сообщение

См. также

Использование сборок .NET в 1С 7. и 8.x. Создание внешних Компонент. Промо

Разработка внешних компонент v7.7 v8 1cv8.cf 1cv7.md Абонемент ($m)

Данная разработка создана для использования сборок .Net в 1С через преобразование объектов и классов в COM-объекты, которые можно использовать в 1С. Достигается это путем создания класса, реализующего методы интерфейса IReflect public class AutoWrap: IReflect.

1 стартмани

28.11.2013    89845    284    Serginio    74    

Разработка игр на языке 1С с использованием Active-X компоненты (собственная разработка)

Разработка внешних компонент v7.7 v8 Россия Абонемент ($m)

Написанная Active-X компонента встраивается на форму обработки 1С (тестировалось на 1С 8.0, 8.1, 8.2, 8.3 не управляемые формы, 1С 7.7.). Компонента предназначена для моделирования игрового поля (вывод, движение спрайтов - фреймов, обработка коллизий, управление спрайтами-фреймами и т.д.) при разработки логики игры на встроенном языке 1С. Приложен пример обработки в которой реализована игра "Бита".

5 стартмани

04.01.2018    17607    2    protexprotex    34    

Компоненты распознавания и печати штрих-кодов

Разработка внешних компонент Сканер штрих-кода v7.7 v8 1cv8.cf 1cv7.md Абонемент ($m)

Комплект программного обеспечения для реализации функций оптического распознавания штрих-кодов различных систем при помощи обычной web-камеры, а также их отображения в печатных формах. Программы могут работать в составе конфигураций, созданных на базе платформ «1С-Предприятие» версий 7.7, 8.2, 8.3. Компонент чтения кодов реализован в виде внешней компоненты 1С с COM-интерфейсом. Компонент отображения создан по стандартной технологии ActiveX для Windows, и может быть встроен в любое приложение, поддерживающее встраивание ActiveX элементов управления, например в документ Word или Excel, или форму VBA. P.S. Добавлена новая версия программы распознавания. Новые функции: обработка видео в реальном режиме (а не по таймеру, как раньше), добавлена возможность распознавания штрих-кодов из графических файлов JPEG, PNG, GIF, BMP, а также передавать для распознавания картинки из 1С, теперь можно получить в 1С захваченное с камеры или файла изображение, как с выделением мест, содержащих коды, так и без, а также отдельные фрагменты изображений, содержащие код. Добавлены новые свойства и методы для программирования. Обновлена документация.

10 стартмани

10.07.2015    74493    89    igorberezhnov    113    

Шаблон внешней компоненты для Lazarus (FreePascal)

Инструментарий разработчика Разработка внешних компонент v7.7 v8 Абонемент ($m)

Шаблон внешней компоненты COM для Lazarus (FreePascal)

1 стартмани

16.05.2014    18112    29    v77    5    

Получение сведений об автомобиле по идентификатору VIN

WEB v7.7 v8 Автомобили, автосервисы Абонемент ($m)

XML RPC сервис для получения сведений об автомобиле по его VIN идентификатору.

1 стартмани

26.12.2013    13789    36    zsrg    13    

Tray Informer

Инструментарий разработчика Разработка внешних компонент Работа с интерфейсом v7.7 v8 Россия Абонемент ($m)

Согласитесь, что окно стандартное сообщений в 1С иногда приносит больше неудобств, чем пользы. И тем более разные "Предупредить"... Что с этим окном только не делают! Его отцепают от формы, делают маленьким, умудряются спрятать за границы экрана. А потом звонят программистам с претензией, что документ почему-то не проводится, отя ничего и не пишет. У вас такого не было? А вот у нас было и не раз )))

1 стартмани

04.09.2013    27839    60    O-Planet    78    

Внешняя компонента для подключения к 1С охранного оборудования производства фирмы Bolid

Внешние источники данных Разработка внешних компонент v7.7 v8 1cv8.cf 1cv7.md Абонемент ($m)

Компонента для считывания ID магнитного ключа посредством охранного оборудованием производства фирмы Bolid (http://www.bolid.ru) через 1С

1 стартмани

04.04.2012    15244    26    andy_zhav    1    

Загрузка прайс-листа с картинками из Excel и работа с буфером обмена

Загрузка и выгрузка в Excel Разработка внешних компонент v7.7 v8 1cv8.cf 1cv7.md Абонемент ($m)

Недавно столкнулся с необходимостью загрузки большого количества прайсов от различных книжных издательств. Обязательным условием было сохранение в базе данных информации вместе с картинками (обложками книг).

1 стартмани

31.07.2010    30655    590    salexdv    32    

Сжатие JPEG и наложение на него водяного знака

Работа с интерфейсом Разработка внешних компонент v7.7 v8 1cv8.cf 1cv7.md Абонемент ($m)

Искал чего-нибудь простое для решения вопроса "Как сжать JPEG и наложить водяной знак". То ли плохо искал, то ли еще никому это не надо было (что вряд ли), посему наваял свое.

1 стартмани

16.07.2010    22596    375    maxpiter    56    

Внешняя компонента для работы с ДубльГИС (2gis.ru)

Разработка внешних компонент Работа с интерфейсом Внешние источники данных v7.7 v8 1cv8.cf 1cv7.md Абонемент ($m)

Предназначена для взаимодействия с системой ДубльГИС (www.2gis.ru) Работает на платформах 1С: 7.7, 8.х

1 стартмани

18.06.2009    21163    641    rustamakhmetov    45    

Переключатель клавиатуры для 1С

Разработка внешних компонент Универсальные функции Сканер штрих-кода v7.7 v8 1cv8.cf 1cv7.md Абонемент ($m)

Переключатель клавиатуры для 1С

1 стартмани

17.06.2009    15523    54    MatveyIgor    2    

Внешняя компонента для работы с Cyberplat

Внешние источники данных Разработка внешних компонент v7.7 v8 1cv8.cf 1cv7.md Абонемент ($m)

С использованием этой внешней компоненты несложно написать свою обработку/конфигурацию для приема платежей в системе киберплат прямо из 1С.

23.09.2008    25858    582    Valerich    78