Консоль запросов + ТЗ как параметры

Публикация № 78001

Разработка - Инструментарий разработчика - Консоль запросов

44
Стандартная консоль запросов, с добавленной возможностью использования описания/заполнения/использования таблиц значений как параметров. Совместима с настройками базовой консоли. Упрощает отладку запросов, использующих временные таблицы.

Ничего сверхестественного - стандартная консоль запросов, с добавленной возможностью использования описания/заполнения/использования таблиц значений как параметров, включающая в себя возможность получения данных временных таблиц под отладчиком в качестве парамеров.

___________

14.05.2019

Добавлена возможность импорта файла, сохраненного при серверном выполнении.

Добавлена закладка "Промежуточные результаты". Позволяет выполнить запрос через функцию  Запрос.ВыполнитьПакетСПромежуточнымиДанными() и вывести данные сложного запроса в виде массива результатов.

 

result_array

 

Упрощена функция получения параметров таблиц в связи с расширением платформенных возможностей по анализу содержимого менеджера временных таблиц.

 

 

Функция АСТ_Сохранить(ТЗ, ИмяФайла = "", Опция = Неопределено) Экспорт
    // создана для удобства переноса таблиц или запросов в консоль запросов - скидывает тз во внешний файл, который можно вычитать консолью запросов
    ЗаписьXML = Новый ЗаписьXML;
    Если ПустаяСтрока(ИмяФайла) Тогда
        ИмяФайла = КаталогВременныхФайлов() + ?(ТипЗнч(ТЗ) = Тип("ТаблицаЗначений"), "copytz.xml", "copyreq.xml") ;
    КонецЕсли;
    Если ТипЗнч(ТЗ) = Тип("Запрос") Тогда
        
        Зн = Новый Структура("Текст, Параметры", ТЗ.Текст, ТЗ.Параметры);
        МассивТаблиц = Новый Массив;

        Если ТипЗнч(Опция) = Тип("Строка") Тогда
            ////////// если опция - строка - значит считаем что передается точный перечень таблиц   
            // прямой перечень таблиц уже не нужен - но оставим если вдруг нежелательно все содержимое менеджера тащить 
            Вр = СокрЛП(Опция);
            Пока СтрНайти(Вр, ",") > 0 Цикл
                Имя = СокрЛП(Лев(Вр,СтрНайти(Вр, ",") - 1));
                Если СтрДлина(Имя) > 0 Тогда
                    МассивТаблиц.Добавить(Имя);
                КонецЕсли;
                Вр = СокрЛП(Сред(Вр, СтрНайти(Вр, ",") + 1));
            КонецЦикла;
            Если СтрДлина(Вр) > 0 Тогда
                МассивТаблиц.Добавить(Вр);
            КонецЕсли;
        ИначеЕсли ТЗ.МенеджерВременныхТаблиц <> Неопределено Тогда //Если Опция = Истина Тогда
            Для каждого Вр из ТЗ.МенеджерВременныхТаблиц.Таблицы Цикл
                МассивТаблиц.Добавить(Вр.ПолноеИмя);
            КонецЦикла;
            // любое другое значение позволяет просто вытащить запрос без временных таблиц 
        КонецЕсли;
        
        // пробуем вытащить значения в параметры
        Для каждого Тб из  МассивТаблиц Цикл
            ТЗВрем = ТЗ.МенеджерВременныхТаблиц.Таблицы.Найти(Тб);
            Если ТЗВрем <> Неопределено Тогда
                Зн.Параметры.Вставить(Тб, ТЗВрем.ПолучитьДанные().Выгрузить());
                Т = "// '" + Тб  + "' таблица вытащена из менеджера временных таблиц и помещена как параметр"  + Символы.ПС;;
                Т = Т + "ВЫБРАТЬ " ;
                Для каждого Кол из Зн.Параметры[Тб].Колонки Цикл
                    Т = Т + Символы.ПС + Символы.Таб + Тб + "." + Кол.Имя + " КАК " + Кол.Имя + "," ;
                КОнецЦикла;
                Т  = Лев(Т, СтрДлина(Т) - 1);
                Т = Т + Символы.ПС + "ПОМЕСТИТЬ " + Тб ;
                Т = Т + Символы.ПС + "ИЗ" + Символы.ПС + Символы.Таб + "&" + Тб + " КАК " + Тб + Символы.ПС + ";" + Символы.ПС + "//////////////////////////////////////////////////////////" + Символы.ПС+ Символы.ПС;
                
                Зн.Текст = Т + Зн.Текст; 
                
            КонецЕсли;
        КонецЦикла;
        
        
    ИначеЕсли ТипЗнч(ТЗ) = Тип("МакетКомпоновкиДанных") Тогда
        Запрос = Новый Запрос;
        Для каждого Параметр из ТЗ.ЗначенияПараметров Цикл
            ЗначПарам = Неопределено;
            Если ТипЗнч(Параметр.Значение) = Тип("СписокЗначений") Тогда
                ЗначПарам = Новый СписокЗначений;
                ЗначПарам.ЗагрузитьЗначения(Параметр.Значение.ВыгрузитьЗначения());
            Иначе
                ЗначПарам = Параметр.Значение;
            КонецЕсли;
            Запрос.УстановитьПараметр(Параметр.Имя,ЗначПарам);
        КонецЦикла;
        
        // определимся с набором
        Если ТипЗнч(Опция) <> Тип("НаборДанныхЗапросМакетаКомпоновкиДанных") Тогда
            // набор явно не указан - пробуем подобрать первый попавшийся набор запрос
            Для каждого Нб из ТЗ.НаборыДанных Цикл
                Если ТипЗнч(Нб) = Тип("НаборДанныхЗапросМакетаКомпоновкиДанных") Тогда
                    Опция = Нб;
                    Прервать;
                КонецЕсли;
            КонецЦикла;
        КонецЕсли;
        
        Если ТипЗнч(Опция) = Тип("НаборДанныхЗапросМакетаКомпоновкиДанных") Тогда
            Запрос.Текст = Опция.Запрос;
            Для каждого Параметр из Опция.ЗначенияПараметров Цикл
                ЗначПарам = Неопределено;
                Если ТипЗнч(Параметр.Значение) = Тип("СписокЗначений") Тогда
                    ЗначПарам = Новый СписокЗначений;
                    ЗначПарам.ЗагрузитьЗначения(Параметр.Значение.ВыгрузитьЗначения());
                Иначе
                    ЗначПарам = Параметр.Значение;
                КонецЕсли;
                Запрос.УстановитьПараметр(Параметр.Имя,ЗначПарам);
            КонецЦикла;
        КонецЕсли;
        Зн = Новый Структура("Текст, Параметры", Запрос.Текст, Запрос.Параметры);
    Иначе
        Зн = ТЗ;    
    КонецЕсли;
    ЗаписьXML.ОткрытьФайл(ИмяФайла, "UTF-8");
    
    #Если Не ТонкийКлиент И НЕ ВебКлиент Тогда
        СериализаторXDTO.ЗаписатьXML(ЗаписьXML, Новый ХранилищеЗначения(Зн ,Новый СжатиеДанных(9)));
    #КонецЕсли
    
    ЗаписьXML.Закрыть();
    Возврат Истина;
КонецФункции

 


03.09.2015

В функции получения запроса в режиме отладки добавлена возможность автоматического определения используемых временных таблиц (переданных через менеджер запросов) и помещения их значений в соответствующий параметр.

Для определения состава временных таблиц осуществляются попытки выполнить запрос, с последующим анализом ошибки (в случае системных сообщений платформы на отличном от русского языка - требуется внести соответствующую правку в текст функции).

Также стоит учитывать, что в процессе автоматического анализа будет запрос будет единожды выполнен. Если само по себе выполнение запроса вызывает проблемы (зависает / либо слишком долго), используйте явное указание списка необходимых временных таблиц.

 

Получение запроса со временными таблицыми под отладчиком

15.11.2013

Данная редакция функции сохранения под отладчиком расширяет возможность отладки сложных запросов, использующих таблицы из менеджеры временных таблиц - в качестве третьего параметра позволяет указывать имена временных таблиц (через запятую), используемых в запросе. Содержимое временных таблиц которых при этом  будет вычитано из менеджера и использовано как параметр-таблица значений.

В качестве экзотического дополнения,  можно указывать МакетКомпоновкиДанных как источник запроса. В этом случае будет запрос будет извлечен из первого набора данных макета, либо можно указать конкретный набор в качестве третьего параметра.

15.11.10/2 Можно использовать результаты выполнения запроса как основание для создания структуры ТЗ и заполнения данными.


23.11.11/1 Добавлена возможность выгружать таблицы в файл / из файла.

10.04.11/1 Добавлена возможность выгружать запросы с параметрами (в т.ч. таблицы значений) в файл / из файла


Для выгрузки таблиц/запросов из конфигуратора в режиме отладки добавьте и используйте функцию

Функция EWG_Сохранить(ТЗ, ИмяФайла = "") Экспорт
    ЗаписьXML = Новый ЗаписьXML;
    Если ПустаяСтрока(ИмяФайла) Тогда
        ИмяФайла = КаталогВременныхФайлов() + ?(ТипЗнч(ТЗ) = Тип("Запрос"), "copyreq.xml", "copytz.xml") ;
    КонецЕсли;
    Зн = ?(ТипЗнч(ТЗ) = Тип("Запрос"), Новый Структура("Текст, Параметры", ТЗ.Текст, ТЗ.Параметры), ТЗ);
    ЗаписьXML.ОткрытьФайл(ИмяФайла, "UTF-8");
    СериализаторXDTO.ЗаписатьXML(ЗаписьXML, Новый ХранилищеЗначения(Зн ,Новый СжатиеДанных(9)));
    ЗаписьXML.Закрыть();
    Возврат Истина;
КонецФункции


 

Примеры обращения под отладчиком  :

EWG_Сохранить(НекийЗапрос.Выполнить().Выгрузить()); // будет выгружена таблица результатов запроса

EWG_Сохранить(НекийЗапрос); // будет выгружен текст запроса с параметрами и всеми используемыми временными таблицами

EWG_Сохранить(НекийЗапрос,, "ВТКонтрагенты, ВТДокументы"); // будет выгружен текст запроса с параметрами плюс времененные таблицы, соответствующие указанным.

 

 

Таблицы в консоль подгружаются через выбор пункта меню консоли "Импорт из файла по-умолчанию" на закладке ТЗ-параметры.

Запросы подгружаются через выбор пункта меню консоли "Импорт из файла по-умолчанию" на основной панели формы, либо через контекстное меню дерева запросов.

 

28.08.12 Мелкие косметические изменения в т.ч. вывод количество строк результата выполнения запроса.

 

44

Скачать файлы

Наименование Файл Версия Размер
Консоль для 8.3
.epf 106,32Kb
14.05.19
428
.epf 070213 106,32Kb 428 Скачать

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. fierylions 05.02.11 09:30 Сейчас в теме
а как её запустить если в самом конфигураторе то просто код показывает если в предприятии то пустое окошечко
2. vec435 15 11.04.12 10:15 Сейчас в теме
при отладке из конфигуратора тз выгружается как отдельный файл или добавляется в параметры?
3. Kashemir 351 11.04.12 11:54 Сейчас в теме
Выгружается в отдельный файл, который можно загрузить в консоли как значение параметра
8. Bukaska 131 15.11.13 14:24 Сейчас в теме
(3) Это консоль для обычного приложения?(ТолстыйКлиент) или для управляемого приложения?(Тонкий клиент)
А то для обычного приложения я как то скачивала консоль: только загрузил запрос - консоль уже создала параметры, остается только ввести значения.
Вот бы для тонкого клиента что-нить такое.. А то другой раз запросы как простыня, чекнешься параметры искать)
9. Kashemir 351 15.11.13 14:34 Сейчас в теме
(8) Bukaska, для толстого клиента.
4. pvlunegov 144 20.04.12 11:28 Сейчас в теме
Спасибо автору за замечательную возможность работы с Таблицами Значений в качестве параметра запроса.
Единственная обработка (консоль запросов) на данном сайте, в которой ПОЛНОСТЬЮ реализована данная функция.

Есть даже сохранение ТЗ в файл запросов. Это просто замечательно!

Смотрел аналогичные консоли, там этой функции или нет, или урезанная, или атрофированная, или без сохранения таблицы в файл запросов.

Всем, кому надо работать с ТЗ и сохранять запросы в файл - рекомендую!
5. MakcTLT63 9 15.11.13 08:51 Сейчас в теме
Глянул скрины. У меня эта обработка хранится под именем EWG_Консользапросов.
Автор позаимствовал идею?
6. Kashemir 351 15.11.13 12:21 Сейчас в теме
(5) MakcTLT63, EWG это аббревиатура мой текущей фирмы. Идея и реализация собственная.
7. MakcTLT63 9 15.11.13 14:20 Сейчас в теме
(6)
Упс.. Прошу прощения за необоснованные подозрения.
Обработка лучшая.
Когда надо поработать с ТЗ она просто незаменима.
10. Kashemir 351 15.11.13 14:41 Сейчас в теме
(7) MakcTLT63, Приятно, что кому-то пригодилась :)
11. desarz 62 05.12.13 15:33 Сейчас в теме
12. sick_russian 05.02.14 06:25 Сейчас в теме
на скрине видно что колонке присваивается тип "СправочникСсылка.Номенклатура", а я такой тип выбрать не могу( почему?
13. Kashemir 351 10.02.14 19:37 Сейчас в теме
Подозреваю что в используемой конфигурации нет справочника "Номенклатура" :)
14. Nebiros777 5 25.02.14 13:31 Сейчас в теме
Удобная штука, постоянно подобной пользуюсь.
15. CaptainMorgan 14.03.14 12:58 Сейчас в теме
А вариант с управляемой формой возможен?
16. oyeah 14.01.15 02:35 Сейчас в теме
(15) CaptainMorgan, Вариант для УФ на диске ИТС RequestConsoleManaged\ИнструментыРазработчикаКонсольЗапросов­83.epf
17. premierex 08.04.15 14:25 Сейчас в теме
Не работает с параметром типа "Список значений", выдаёт ошибку "{(1,1)}: Переменная не определена (Прочее)
<<?>>Прочее", где "Прочее" - элемент справочника, заданного в параметре типа "Список значений". Да и сам подбор в список очень уж неудобно организован: тип выбирается из длинного выпадающего меню. Пока до самого низа его прокрутишь, чтобы необходимый тип выбрать, уже и желание пропадает этой консолью пользоваться.
18. unichkin 1251 03.09.15 21:33 Сейчас в теме
19. Kashemir 351 04.09.15 10:53 Сейчас в теме
(18) unichkin, Безусловно - но не всегда космический корабль удобнее автомобиля.
20. user645364_roman_sh 10.06.18 18:05 Сейчас в теме
Вот здесь выполняется запрос ОтладочныйЗапрос, для которого нет никаких параметров кроме параметров типа таблица значений.
Попытка
ОтладочныйЗапрос.Выполнить();
Исключение
ТекстОшибки = ОписаниеОшибки();
Продолжить;
КонецПопытки;

Почему не копируются параметры сразу? Например после строк

ОтладочныйЗапрос.Текст = ТЗ.Текст;
//по идее должны следовать строки
Для Каждого ЭлементСтруктуры Из Зн.Параметры Цикл
ОтладочныйЗапрос.Параметры.Вставить(ЭлементСтруктуры.Ключ, ЭлементСтруктуры.Значение);
КонецЦикла;
22. Kashemir 351 21.06.18 03:55 Сейчас в теме
(20) Параметры так и копируются. Через попытку вытягиваются обращения ко временным таблицам. Альтернативой может служит только полноценный синтаксический анализатор, но даже он не сможет типизировать данные временные таблицы.
По мере получения ошибок при обращениях к данным временным таблицам появляется возможность изнать их имена, после чего можно через * выгрузить их из менеджера со всеми типизациями определенными для них в термах 1С.
21. user645364_roman_sh 10.06.18 18:28 Сейчас в теме
Второе замечание касается случаев когда МенеджерВременныхТаблиц запроса ТЗ содержит временные таблицы со значениями полей Неопределено или Null. Тогда начинает ругаться что при выполнении запроса ОтладочныйЗапрос эти его поля нетипизированные. Здесь может помочь вариант их к-л массово типизировать. Я в этом случае таким полям до использования функции EWG_Сохранить присвоил пустые ссылки в запросе используя Значение(справочник. и т.д...Понимаю некорректно, но по-другому не придумал.
23. Kashemir 351 21.06.18 04:00 Сейчас в теме
24. RailMen 788 11.09.18 19:06 Сейчас в теме
Допилил консольку так: сделал кнопку "Загрузить таблицу из excel". При загрузке из excel автоматом задаются типы колонок.

Прикрепленные файлы:
EWG_Консользапросов (Консоль запросов + ТЗ как параметры 8.2) 2.epf
Оставьте свое сообщение

См. также

Подборка программ для взаимодействия с ЕГАИС Промо

ЕГАИС (Единая государственная автоматизированная информационная система) - автоматизированная система, предназначенная для государственного контроля за объёмом производства и оборота этилового спирта, алкогольной и спиртосодержащей продукции. Инфостарт рекомендует подборку проверенных решений для взаимодействия с системой.

Консоль запросов для ЗУП 3.х 27

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8::Запросы ЗУП3.x Россия Абонемент ($m) Консоль запросов

Доработка стандартной консоли запросов для работы с механизмом представлений из ЗУП 3.х.

1 стартмани

05.11.2019    2310    17    evgeni-red    5       

Консоль запросов управляемая с конструктором 1

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Windows Абонемент ($m) Консоль запросов

Обработка Консоль запросов позволяет использовать полноценный функционал конструктора и получать план выполнения запроса. Так же главная отличительная особенность от аналогов - то что она работает.

1 стартмани

17.10.2019    1672    5    ogidni    27       

Перенос документов и справочников ERP 2 / КА 2 / УТ 11 => БП 3.0 Промо

Перенос позволяет настроить собственный обмен данными между указанными программами, альтернативный предлагаемому фирмой 1С. Предоставляем техподдержку по всем вопросам данного обмена. Можем подключиться к вам удаленно для разбора ситуаций. Оперативно обновляем при выходе новых релизов 1С. Бесплатные обновления в течение полугода.

19700 руб.

Консоль запросов с перехватом отчетов СКД (для получения реального текста запроса) и запросов 14

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8::Запросы v8::СКД 1cv8.cf Россия Абонемент ($m) Консоль запросов

Доработанная консоль запросов с автоматическим заполнением текста запроса и всех параметров на основании объекта Запрос, полученного в "Конфигураторе" или перехваченного встроенного/внешнего отчёта СКД.

1 стартмани

29.09.2019    2427    9    strek_ivan    3       

Новый раздел на Инфостарте - Electronic Software Distribution Промо

Инфостарт напоминает: на нашем сайте можно купить не только ПО, связанное с 1С. В нашем арсенале – ESD-лицензии на ПО от ведущих вендоров: Microsoft, Kaspersky, ESET, Dr.Web, Аскон и другие.

  • Низкие цены, без скрытых платежей и наценок
  • Оперативная отгрузка
  • Возможность оплаты с личного счета (кешбек, обмен стартмани на рубли и т.п.)
  • Покупки идут в накопления для получения скидочных карт лояльности Silver (5%) и Gold (10%)

Консоль запросов с возможностью сравнения данных между базами (управляемые формы) 18

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 v8::УФ v8::Запросы 1cv8.cf Россия Абонемент ($m) Консоль запросов

Данная консоль позволяет сравнивать любые данные полученные произвольными запросами между текущей базой и внешней базой данных как файловой, так и клиент-серверной.

3 стартмани

26.08.2019    2171    19    Dadriel619960    9       

Встраиваем консоль запросов для отбора в стандартные обработки 1С 11

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Консоль запросов

Данное руководство поможет встроить форму отбора в стандартные обработки 1С, например "Групповое изменение реквизитов" или "Поиск и удаление дублей". Бывает случаи, что нужно сделать сложный отбор элементов, который невозможно реализовать через стандартный отбор или, в случае поиска и удаления дублей, справочник имеет тысячи элементов и поиск по нему дублей может знять даже не один день. Тут на помощь приходит консоль запросов, которая встраивается в обработки и помогает отобрать нужные элементы для дальнейших с ними действий.

1 стартмани

01.03.2019    2810    2    w.r.    3       

Программы для исполнения 54-ФЗ Промо

С 01.02.2017 контрольно-кассовая техника должна отправлять электронные версии чеков оператору фискальных данных - правила установлены в 54-ФЗ ст.2 п.2. Инфостарт предлагает подборку программ, связанных с применением 54-ФЗ, ККТ и электронных чеков.

Консоль запросов с их сохранением в базе 2

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Казахстан Абонемент ($m) Консоль запросов

Консоль запросов стандартная, предназначена для создания и выполнения запросов в режиме предприятия с помощью конструктора запросов или вручную. Долгое время использовал эту стандартную консоль запросов и даже научил нескольких бухгалтеров пользоваться ею, и понял, что основное неудобство - это хранение запросов во внешних файлах, когда копии запросов расползаются по рабочим столам, и бухгалтера (да и я ) должны помнить, где лежит последняя версия запроса. И тогда мне пришла мысль хранить их в самой базе, что я и реализовал. При этом возможности штатного сохранения\чтения в/из внешних файлов осталась неизменной.

1 стартмани

26.02.2019    2341    makfromkz    9       

Перенос данных КА 1.1 / УПП 1.3 => БП 3.0 (перенос остатков, документов и справочников из "1С:Комплексная автоматизация 1.1" / УПП 1.3 в "1С:Бухгалтерия 3.0"). Обновлен до версий КА 1.1.115.х, УПП 1.3.127.х! Промо

Разработка позволяет перенести остатки по всем счетам бух.учета в программу "1С:Бухгалтерия предприятия 8", ред. 3.0 на выбранную дату начала ведения учета. Также переносятся документы за период и вся необходимая справочная информация. Правила оперативно обновляю при выходе новых релизов. Рассылка обновлений правил бесплатно в течение 12 месяцев. Есть видеодемонстрация проведения переноса данных. Конфигурации при использовании обмена остаются полностью типовыми. Перенос данных возможен в Бухгалтерию 3.0 версии ПРОФ, КОРП или базовую.

24700 руб.

Консоль запросов (управляемые формы) + возможность работы в толстом клиенте 1

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Windows Абонемент ($m) Консоль запросов

Одна обработка для Толстого и тонкого клиента. Работает как на управляемых, так и не управляемых формах. Заброс получился большой и громоздкий - ГДЕ ТОРМОЗИТ? Нужно писать в консоли для обработки и часть параметров не используется? 1С зависла при выполнения запроса и текст запроса потерян, а авто сохранение не любите, т.к. он при ошибке не оставляет вам вариантов - ошибка уже вписалась?! Тестируете обработку Табличных Частей документа? Толстый клиент проверен на 8.2.19.130, Управл. формы на 8.3.10.2580. УФ Оптимизация под такси, но нормально под простой интерфейс.

1 стартмани

17.01.2019    2767    7    Sevg    0       

Выгрузка запроса из отладки в консоль запросов (Управляемые формы) 5

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8::УФ v8::Запросы 1cv8.cf Россия Абонемент ($m) Консоль запросов

Помощник в отладке и доработке запросов использующих менеджер временных таблиц.

1 стартмани

13.11.2018    4281    4    redtram    2       

Новогодние скидки на авторское ПО Промо

В преддверии праздника в Маркетплейсе на Инфостарт действует скидка на все платные авторские программы. Размер скидок начинается от 10%. Советуем не откладывать покупки, многие наши партнеры повышают цены на свои продукты именно в начале нового года.

Консоль запросов для управляемых форм 8.3 19

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 v8::УФ v8::Запросы 1cv8.cf Windows Абонемент ($m) Консоль запросов

Универсальная внешняя обработка (СДРКонсольЗапросовХ) для создания, редактирования и отладки запросов, с возможностью обработки таблицы результатов произвольными алгоритмами на языке 1С. Выгрузка результатов запроса в таблицу или дерево значений, включая временные таблицы и запросы пакета. Формирование запроса для консоли в отладчике, включая временные таблицы и параметры. Версия 1.1.0.41 от 26.11.2019

3 стартмани

08.11.2018    8061    74    ROL32    8       

Консоль запросов 2

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8::УФ v8::Запросы 1cv8.cf Абонемент ($m) Консоль запросов

Консоль запросов для УФ. Внешне похожа на консоль для обычного приложения. Но есть ряд новых возможностей.

1 стартмани

25.06.2018    6676    16    17808849    10       

Готовые переносы данных из различных конфигураций 1C Промо

Рекомендуем готовые решения для переноса данных из различных конфигураций 1C. C техподдержкой от разработчиков и гарантией от Инфостарт.

Консоль HTTP-запросов с генерацией кода 164

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Абонемент ($m) Консоль запросов

Консоль HTTP-запросов, которая не только выполняет запросы и получает результат их выполнения, но и генерирует необходимый код. Использую на 8.3.11.2899.

1 стартмани

25.05.2018    16180    220    leongl    15       

Униформальная консоль запросов 106

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8::УФ v8::Запросы 1cv8.cf Абонемент ($m) Консоль запросов

Минималистичная и функциональная консоль запросов, которая выглядит и работает одинаково, как в обычных формах, так и в управляемых.

1 стартмани

23.05.2018    17775    281    Synoecium    50       

Перенос данных УТ 10.3 => УТ 11 / КА 2 / ERP 2 (ЕРП 2) (документы, остатки и справочная информация из "1С:Управление торговлей, ред. 10.3" в УТ 11 / КА 2 / ERP 2). Обновлен до УТ 10.3.56.х, УТ 11.4.10.х, КА 2.4.10.х и ERP 2.4.10.х! Промо

Уже более 100 компаний приобрели перенос и выполнили переход на УТ 11 / КА 2 / ERP 2 с помощью нашей разработки! Обработка перехода с УТ 10.3 на УТ 11 / КА 2 / ERP 2 позволяет перенести не только остатки на указанную дату (как типовой перенос), но и все возможные документы за выбранный период. При выходе новых релизов этих программ оперативно выпускаем обновление обработки. Предоставляем техническую поддержку. Можем сделать бесплатный тестовый перенос!

29700 руб.

Групповая обработка реквизитов + консоль запросов 13

Инструменты и обработки Программист Расширение (cfe) v8 v8::УФ v8::Запросы Розница УНФ БП3.0 УТ11 КА2 Абонемент ($m) Консоль запросов

Расширение конфигурации, которое в типовую обработку "Групповое изменение реквизитов" добавляет возможность отбирать объекты для обработки запросом. Необходимо наличие обработки "Консоль запросов" с ИТС.

2 стартмани

20.03.2018    12773    42    Kutuzov    6       

Консоль запросов со встроенным Конструктором запросов для 1с8.3 (8.2) своими руками 12

Статья Программист Внешняя обработка (ert,epf) v8 v8::УФ v8::Запросы 1cv8.cf Абонемент ($m) Консоль запросов

Мы можем сами создать свою консоль запросов - именно такую, которая подходит для наших нужд. Кроме того, создав собственную Консоль запросов, Вы не только получаете удобный для себя инструмент, а также получаете навык программирования в среде 1с8, что очень полезно будет начинающим программистам 1С.

1 стартмани

21.12.2017    16645    54    jan-pechka    23       

С 2020 года сервис «Продление поддержки конфигурации 1С:УПП» подорожает вдвое Промо

Успейте продлить поддержку УПП до повышения цен! Фирма «1С» предупредила об изменении цен на сервис «Продление поддержки конфигурации "1С:Управление производственным предприятием"». С 1 января 2020 года сервис подорожает в два раза.

Консоль запросов: работа с временными таблицами 3

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 v8::Запросы 1cv8.cf Россия Абонемент ($m) Консоль запросов

Консоль запросов помогает сэкономить время при работе со сложными запросами со временными таблицами.

1 стартмани

12.12.2017    6637    9    lapa_kn    1       

Консоль запросов OData 15

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Консоль запросов

Консоль запросов по протоколу OData.

1 стартмани

30.08.2017    14631    69    vlsv    6       

1C:Предприятие для программистов: Запросы и отчеты. Второй поток. Онлайн-интенсив с 17 марта по 16 апреля 2020 г. Промо

Данный онлайн-курс предусматривает углубленное изучение языка запросов и возможностей системы компоновки данных, которые понадобятся при разработке отчетов, работающих на платформе “1С:Предприятие” в рамках различных прикладных решений. Курс предназначен для тех, кто уже имеет определенные навыки конфигурирования и программирования в системе “1С:Предприятие”, а также для опытных пользователей различных прикладных решений, которые используют в своей работе отчеты разного назначения.

6500 рублей

Консоль запросов 8.3 (обычное приложение) с возможностью переноса параметров запроса через строку (из отладки). А также с возможностью очень быстрой выгрузки больших объемов данных в Excel(CSV) исключительно мощностями сервера 11

Инструменты и обработки Системный администратор Программист Внешняя обработка (ert,epf) v8 1cv8.cf Россия Казахстан Абонемент ($m) Консоль запросов

Доработанная консоль запросов для 1С 8.3. Доработанные функции: 1. Загрузка параметров запроса из строки, полученной в отладке методом ЗначениеВСтрокуВнутр(Запрос.Параметры) 2. Выгрузка результата запроса в CSV файл на сервере и передача его на клиент. Быстрее в 10 раз чем стандартное "Сохранить Как" 3. Получение на основание запроса кода для выполнения обработки. При этом в коде уже прописаны все установленные для запроса параметры, а так же типизировано основное поле результата. 4. Конвертация текста запроса из вложенных запросов, во временные таблицы

1 стартмани

09.07.2017    10765    28    matveev.andrey.v    0       

Консоль запросов с графом (Анализатор сложных запросов) 343

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8::УФ v8::Запросы 1cv8.cf Windows Абонемент ($m) Консоль запросов

Консоль запросов для анализа запросов с большим количеством временных таблиц и вложенных запросов. Отображает структуру взаимосвязей временных таблиц в виде графа. Позволяет быстро передвигаться по тексту запроса и получать результат выполнения подзапросов. Единственная консоль запросов, которая позволяет выводить результат выполнения вложенных запросов и любой части объединения запроса. Удобное получение данных запроса из отладчика включая временные таблицы. Текст запроса в структурированном виде (можно свернуть, развернуть текст подзапроса). И еще много другого, чего вы не найдете в других консолях запросов. Поддержка УФ и ОФ. Версия 0.9.1 от 18.10.2019 (поддержка WebKit).

10 стартмани

03.05.2017    87924    381    manuel    232       

Перенос данных УПП 1.3 => ERP 2 (ЕРП) / УТ 11 / КА 2.х (обработка переноса документов, остатков и справочников из "1С:Управление производственным предприятием, ред. 1.3" в ERP / УТ 11 / КА 2). Обновлен до УПП 1.3.127.х, КА 2.4.10.х и ERP 2.4.10.х! Промо

Обработка позволяет переносить из УПП 1.3 в ERP 2 документы за выбранный период и остатки. Типовая обработка от фирмы 1С документы не переносит. Также исправлены ошибки типовой обработки. При выходе новых релизов обновление высылается бесплатно в течение года. Разработка будет полезна фирмам-франчайзи, которые периодически выполняют такой перенос данных для заказчиков. Вы можете один раз приобрести обработку переноса, и потом бесплатно получать обновления при выходе новых релизов конфигураций 1С.

29700 руб.

Консолька (версия 6.0.43) 19

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8::УФ v8::Запросы 1cv8.cf Беларусь Абонемент ($m) Консоль запросов

Обработка Консолька предназначена для выполнения запросов к информационной базе 1С в режиме управляемого приложения, выполнения запросов к базам данных SQL, выполнения произвольного кода 1С.

1 стартмани

27.02.2017    16682    67    sertak    27       

Подборка решений для взаимодействия со ФГИС «Меркурий» Промо

С 1 июля 2019 года все компании, участвующие в обороте товаров животного происхождения, должны перейти на электронную ветеринарную сертификацию (ЭВС) через ФГИС «Меркурий». Инфостарт предлагает подборку программ, связанных с этим изменением.

Консоль запросов EX (внешние данные) 15

Инструменты и обработки Системный администратор Программист Внешняя обработка (ert,epf) v8 1cv8.cf Windows Абонемент ($m) Консоль запросов

Работа с внешними данными в консоли запросов (1С 7.7, 8.x, XBase, Excel, ADO)

1 стартмани

30.10.2016    5720    25    Cерый    0       

Консоль запросов SQL 11

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Windows Абонемент ($m) Консоль запросов

Иногда возникает желание посмотреть, как информация 1С уложена в базе данных. Данная обработка позволяет показать структуру базы данных, а так же обычными SQL-запросами просмотреть содержимое таблиц MsSQL.

1 стартмани

21.10.2016    7758    45    igel9780    8