Кнопка ПОДБОР для документа Заявка на открытие лицевых счетов

Публикация № 1150965

Администрирование - Администрирование данных 1С - Обработка документов

заявка открытие ЗУП ЗКГУ подбор 19 символов лицевой счет XML

Расширение добавляет кнопку "Подбор" в документ "Заявка на открытие лицевых счетов". И отключает проверку на 19 символов в латинском Фамилии, Имени при выгрузке.

По кнопке "Подбор" открывается форма списка сотрудников работающих на дату документа.

Если сотрудник работает по основному месту и внутреннему совместительству, то в документ попадет одно физическое лицо.

К сожалению при подборе не подсвечиваются уже выбранные сотрудники, т.к. форма подбора отражает справочник сотрудники, а в документе справочник физические лица.

В расширении следует отключить безопасный режим.

Тестировалась на: Зарплата и кадры государственного учреждения, редакция 3.1 (3.1.9.229).

 

Пример кода из расширения (кнопка подбор):

&НаКлиенте
Процедура Расш_ПодборЗаявкаНаОткрытиеПодборСотрудниковПосле(Команда)
	
	//ПерсонифицированныйУчетКлиент.ПодобратьФизическихЛиц(Элементы.ЛицевыеСчета, Объект.Организация, АдресСпискаПодобранныхСотрудников());
	
	ПараметрыОткрытия = Новый Структура;
	
	Отборы = Новый Структура("ПоказыватьДоговорниковГПХ", Ложь);
	ПараметрыОткрытия.Вставить("Отбор", Отборы);
			
	КадровыйУчетКлиент.ВыбратьСотрудниковРаботающихВПериодеПоПараметрамОткрытияФормыСписка(
		Элементы.ЛицевыеСчета,
		Объект.Организация,
		,
		НачалоДня(Объект.Дата),
		КонецДня(Объект.Дата),
		,
		АдресСпискаПодобранныхСотрудников(),
		ПараметрыОткрытия);

КонецПроцедуры

&НаКлиенте
Процедура Расш_ПодборЗаявкаНаОткрытиеЛицевыеСчетаОбработкаВыбораПосле(Элемент, ВыбранноеЗначение, СтандартнаяОбработка)
	
	 ЗаполнитьСтрокуНаСервереПосле(ВыбранноеЗначение);

КонецПроцедуры

&НаСервере
Процедура ЗаполнитьСтрокуНаСервереПосле(ВыбранноеЗначение)
	
	Валюта = Справочники.Валюты.НайтиПоКоду("643");
	
	СписокФизическихЛиц = Новый ТаблицаЗначений();
	СписокФизическихЛиц.Колонки.Добавить("ФизическоеЛицо", Новый ОписаниеТипов("СправочникСсылка.ФизическиеЛица"));
	
	Для каждого Строка Из ВыбранноеЗначение Цикл
		
		НоваяСтрока = СписокФизическихЛиц.Добавить();
		НоваяСтрока.ФизическоеЛицо = Строка.ФизическоеЛицо;
		
	КонецЦикла;
	
	СписокФизическихЛиц.Свернуть("ФизическоеЛицо");
	
	Для каждого Строка Из СписокФизическихЛиц Цикл
		
		НоваяСтрока = Объект.Сотрудники.Добавить();
		НоваяСтрока.ФизическоеЛицо = Строка.ФизическоеЛицо;
		
		ДокументОбъект = РеквизитФормыВЗначение("Объект");
		ДокументОбъект.ЗаполнитьСтрокуТабличнойЧастиДаннымиДляОткрытияЛицевыхСчетов(ДокументОбъект.Дата, НоваяСтрока.НомерСтроки);
		ЗначениеВРеквизитФормы(ДокументОбъект, "Объект")
		
	КонецЦикла;
	
	Для каждого Строка Из Объект.Сотрудники Цикл
		
		//Строка.ЯвляетсяЗарплатнойКартой = Истина;
		Строка.СистемаРасчетовПоБанковскимКартам = "МИР";
		Строка.ВалютаВклада = Валюта;
		
	КонецЦикла;
		
КонецПроцедуры

 

Скачать файлы

Наименование Файл Версия Размер
Кнопка ПОДБОР для документа Заявка на открытие лицевых счетов:

.cfe 49,55Kb
08.11.19
18
.cfe 49,55Kb 18 Скачать

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. DJDUH 17 08.11.19 15:29 Сейчас в теме
Запрос в цикле, ай-я-я-й-й!!!

Для каждого Строка Из Объект.Сотрудники Цикл
		
	//Строка.ЯвляетсяЗарплатнойКартой = Истина;
	Строка.СистемаРасчетовПоБанковскимКартам = "МИР";
	Строка.ВалютаВклада = Справочники.Валюты.НайтиПоКоду("643");
		
КонецЦикла;
Показать



Валюта643 = Справочники.Валюты.НайтиПоКоду("643");
Для каждого Строка Из Объект.Сотрудники Цикл
		
	//Строка.ЯвляетсяЗарплатнойКартой = Истина;
	Строка.СистемаРасчетовПоБанковскимКартам = "МИР";
	Строка.ВалютаВклада = Валюта643 ;
		
КонецЦикла;
Показать
2. GeterX 796 08.11.19 17:04 Сейчас в теме
3. chesnokov-a-v 99 17.12.19 14:35 Сейчас в теме
Установил расширение, но кнопка "Подбор" не появилась. ЗУП 3.1.11.133
4. GeterX 796 17.12.19 14:40 Сейчас в теме
(3) в описании написано: "В расширении следует отключить безопасный режим."
5. chesnokov-a-v 99 17.12.19 20:06 Сейчас в теме
(4) конечно это было сделано. попробую разобраться в проблеме чуть позже.
6. GeterX 796 17.12.19 20:24 Сейчас в теме
(5) попробуйте поискать в меню Ещё табличной части документа.
7. chesnokov-a-v 99 18.12.19 11:28 Сейчас в теме
(6) Появилась. Удалил расширение и добавил заново, с несколькими перезапусками (магия).
8. Amras 43 20.12.19 09:41 Сейчас в теме
Так попроще будет, а уж добавить команду (ПодобратьСотрудников) на форму, думаю, труда не составит. И при всем при этом используем исключительно типовые механизмы (протестировано на ЗУП КОРП 3.1.10.223), кроме получения ФизическогоЛица.

&НаКлиенте
Процедура ПодобратьСотрудников(Команда)
	КадровыйУчетКлиент.ВыбратьСотрудниковРаботающихНаДатуПоПараметрамОткрытияФормыС­писка(
		Элементы.ЛицевыеСчета,,,,,АдресСпискаПодобранныхСотрудников());
КонецПроцедуры
	
// Возвращает адрес во временном хранилище массива уже подобранных сотрудников.
//
&НаСервере
Функция АдресСпискаПодобранныхСотрудников()
	СписокСотрудников = Объект.Сотрудники.Выгрузить(,"ФизическоеЛицо").ВыгрузитьКолонку("ФизическоеЛицо");
	
	Возврат ПоместитьВоВременноеХранилище(СписокСотрудников, УникальныйИдентификатор);
КонецФункции

&НаКлиенте
Процедура ЛицевыеСчетаОбработкаВыбора(Элемент, ВыбранноеЗначение, СтандартнаяОбработка)
	Для каждого ВыбранныйСотрудник Из ВыбранноеЗначение Цикл
		
		мФизЛицо = МГ_ПолучитьФизЛицо(ВыбранныйСотрудник);
		
		Если Объект.Сотрудники.НайтиСтроки(Новый Структура("ФизическоеЛицо", мФизЛицо)).Количество() = 0 Тогда
			НовыйСотрудник = Объект.Сотрудники.Добавить();
			НовыйСотрудник.ФизическоеЛицо = мФизЛицо;
			
			ЗаполнитьСтрокуНаСервере(НовыйСотрудник.НомерСтроки);
			
			Модифицированность = Истина;
		КонецЕсли;
	КонецЦикла; 
КонецПроцедуры

&НаСервере
Функция МГ_ПолучитьФизЛицо(Сотрудник)
	Возврат Сотрудник.ФизическоеЛицо;
КонецФункции
Показать
Evgeniy_stv; +1 Ответить
9. mart1120 26.05.20 18:09 Сейчас в теме
Скачала для ЗУП 3.1. Не работает.
Ошибка: Не удалось добавить расширение. ....
....
Ошибка применения расширения конфигурации: Значение контролируемого свойства Режим совместимости у объекта не совпадает со значением расширяемой конфигурации.


Можно поправить?
12. GeterX 796 26.05.20 20:25 Сейчас в теме
(9) расширение поправлю.
а сейчас чтобы повторно не скачивать, установите расширение через конфигуратор, и в свойствах расширения снимите галку с совместимости.
Прикрепленные файлы:
10. mart1120 26.05.20 18:33 Сейчас в теме
Платформа 8.3.15.1830
конфигурация ЗУП 3.1.13.188
11. mart1120 26.05.20 19:39 Сейчас в теме
На старых релизах работает. Проверяла.
13. mart1120 26.05.20 21:24 Сейчас в теме
Спасибо! Все получилось!
Оставьте свое сообщение

См. также

Альтернативный способ добавления элементов и реквизитов на формы Промо

Работа с интерфейсом v8 ERP2 УТ11 Россия Абонемент ($m)

Предлагаю альтернативный вариант добавления динамически создаваемых элементов и реквизитов на форму.

1 стартмани

09.09.2019    10867    12    bmk74    3    

Списание (корректировка) задолженности контрагентов УНФ 1.6

Закрытие периода Дебиторская и кредиторская задолженность Обработка документов Дебиторская и кредиторская задолженность v8 УНФ Украина БУ Абонемент ($m)

Обнуление задолженности контрагентов в конфигурации "Управление небольшой (нашей) фирмой" версии 1.6 с помощью документа "Корректировка регистров".

1 стартмани

24.07.2019    21340    13    DMon    1    

Регистрация документов с измененной суммой

Обработка документов v8 1cv8.cf Абонемент ($m)

Обработка берет информацию из истории изменения документов. Удобна для администраторов, когда документы с измененной суммой по какой-то причине не регистрируются в плане обменов. Можно регистрировать не все документы, а только те, которые были изменены.

1 стартмани

20.04.2019    18028    3    ryan    0    

Валовая прибыль для УПП 1.3, КА 1.1 в режиме РАУЗ (работа типового отчета без доработок конфигурации)

Обработка документов v8 КА1 УПП1 УУ Абонемент ($m)

Простое и мгновенное решение для использования типового отчета "Валовая прибыль" в конфигурациях "Управление производственным предприятием 1.3", "Комплексная автоматизация 1.1" (а также отраслевых решений на их базе) при включенном режиме РАУЗ (расширенная аналитика учета затрат). Не требует настройки или изменения конфигурации, либо может быть, для дополнительного удобства, интегрировано в нее с минимальными доработками.

2 стартмани

21.01.2019    18261    20    stvorl    11    

Помощник по закрытию месяца для УТ 11.3 Промо

Закрытие периода Обработка документов Закрытие периода Закрытие периода v8 v8::ОУ УТ11 Россия УУ Абонемент ($m)

Помощник по закрытию месяца для УТ 11.3. Имеет две функции: обнуление товаров "К оформлению" в интеркампани и обнуление отрицательных остатков в регистре "Себестоимость товаров".

5 стартмани

10.11.2017    22945    26    Zalipaka    1    

Открывашка ячеек таблиц

Работа с интерфейсом v8 1cv8.cf Абонемент ($m)

Глобальное сочетание клавиш для открытия объекта по ссылке из текущей ячейки любой таблицы в большинстве управляемых форм

1 стартмани

27.10.2018    16519    12    tormozit    31    

Универсальный инструмент для переноса данных через табличный документ (УФ)

Обработка документов Универсальные обработки Обработка справочников v8 v8::УФ 1cv8.cf Абонемент ($m)

Для опытных пользователей, разработчиков, администраторов, консультантов

5 стартмани

15.10.2018    32557    120    json    40    

Помощник корректировки остатков ЕГАИС в небольшом магазине. Розница 2.2

Розничная торговля Обработка документов Розничная торговля v8 Розница Розничная и сетевая торговля (FMCG) Рестораны, кафе и фаст-фуд Россия УУ Абонемент ($m)

Данная обработка упрощает корректировку остатков алкогольной продукции небольшого магазина, где предполагается передача всей продукции в торговый зал сразу после приемки.

5 стартмани

08.09.2018    31467    82    asdfgcom    46    

Расширение резервов отпусков

Обработка документов Зарплата Зарплата v8 v8::СПР ERP2 ЗКГУ3.0 ЗУП3.x Россия БУ Абонемент ($m)

Произвольная настройка базы для расчета резервов отпусков.

2 стартмани

10.08.2018    25651    51    СергейКа    16    

Визуализация событий на временной шкале средствами "Поле HTML документа"

Работа с интерфейсом v8 1cv8.cf Абонемент ($m)

Интересный способ наглядно отобразить события на временной шкале. Например, может быть применен для красивого вывода документов по клиенту. Тестировалось на платформе 8.3.12.1469

1 стартмани

31.07.2018    23170    138    Plotks2017    27    

Работа с данными выбора

Практика программирования Работа с интерфейсом v8 Россия Абонемент ($m)

В управляемом интерфейсе заложена мощная возможность описывать связи реквизитов формы через параметры. Установка параметров связей позволяет ограничить выбор данных так, чтобы целостность данных была обеспечена на этапе ввода. Однако без дополнительного программирования задать можно только самые простые связи. Такие условия связи, как зависимость от реквизита через точку или зависимость через дополнительное отношение, заданное в регистре сведений - уже задать без программирования не получится.

1 стартмани

17.07.2018    44971    17    kalyaka    16    

Прыг-Скок...или из MS EXCEL в 1С (8.2) (открытый код) Промо

Обработка документов Обработка справочников Загрузка и выгрузка в Excel v8 1cv8.cf Абонемент ($m)

Универсальная загрузка данных из Microsoft Office Excel. Автоматическая загрузка из любых по форме документов с очень удобным редактором. Почти готовый шаблон для любой конфигурации. Не требует регистрации-бесплатно.

1 стартмани

16.09.2015    62089    357    Tatitutu    48    

Корректировка остатков ЕГАИС, возврат из регистра 2, загрузка ТТН из файлов, другое для УТ10.3

Розничная торговля Обработка документов Розничная торговля v8 v8::ОУ УТ10 Россия БУ Абонемент ($m)

Набор обработок для автоматизации работы с ЕГАИС: Обработка корректировки остатков ЕГАИС для УТ 10.3, аналогичная имеющимся в УТ 11, Рознице 2.2. Автоматически формирует документы "Передача в торговый зал", "Акт постановки на баланс в торговом зале", "Акт списания в торговом зале". Обработка возврата из регистра 2 с подбором справок Б. Обработка формирования ТТН из файлов xml.

1 стартмани

24.01.2018    34287    29    biz-intel    5    

Расчет начисления зарплаты со сложной формулой, по данным из внешнего источника. ЗУП 3.1

Обработка документов Загрузка и выгрузка в Excel Зарплата Зарплата v8 v8::СПР ЗКГУ3.0 ЗУП3.x БУ Абонемент ($m)

Расчет начисления зарплаты со сложной формулой, по данным из внешнего источника по данным экономического отдела. ЗУП 3.1.

3 стартмани

20.12.2017    47412    31    mvv1975    7    

Копирование меню в Трактир Management

Обработка документов Производство готовой продукции (работ, услуг) Производство готовой продукции (работ, услуг) v8 1cv8.cf Рестораны, кафе и фаст-фуд Россия УУ Абонемент ($m)

Механизм копирования меню в Трактир Management. Данная обработка расширяет функционал типового решения Трактир Management, позволяя быстро вводить в эксплуатацию новую точку путём создания нового меню на основании имеющегося.

1 стартмани

28.11.2017    27364    4    integrator1983    0    

Перемещение остатков по счету МЦ04 между материально ответственными лицами для конфигураций (8.2). Промо

Обработка документов Универсальные обработки Учет ТМЦ Учет ТМЦ v8 БП2.0 Россия БУ Абонемент ($m)

Небольшая обработка, которая позволяет перекидывать остатки по счету МЦ04 с одного материально ответственного лица на другое

1 стартмани

22.11.2012    14209    13    niksaf    4    

Программное формирование форматированной строки в стиле html+inline CSS

Работа с интерфейсом Инструментарий разработчика v8 1cv8.cf Абонемент ($m)

Если вам приходилось работать с форматированными строками программно, то вы знаете, какая это боль. Данное решение облегчает программное формирование таких строк.

1 стартмани

18.11.2017    30876    33    bonv    10    

Расширенная настройка динамического списка УФ Промо

Работа с интерфейсом v8 v8::УФ 1cv8.cf Абонемент ($m)

Открывая управляемую форму выбора и не увидев там видимых в форме списка элементов, часто хочется узнать причину их отсутствия там, т. е. какой наложен отбор. Но стандартная настройка списка управляемой формы показывает только пользовательские настройки, скрывая от пользователя фиксированный отбор. Предлагаю вам расширение конфигурации с расширенной настройкой динамического списка, отображающей пользователю кроме пользовательских настроек еще фиксированные.

1 стартмани

31.05.2017    31660    149    tormozit    23    

Упрощение работы с актами сверки в УТ/КА/УПП - вывод номеров счетов в документе и печатной форме

Обработка документов Печатные формы документов Дебиторская и кредиторская задолженность Дебиторская и кредиторская задолженность v8 КА1 УТ10 УПП1 БУ УУ Абонемент ($m)

Обычно акт сверки с клиентами содержат информацию о документах реализации товаров (накладных) и выполненных платежах. Но платежи делаются на основании счетов, номера которых отсутствуют в актах, что затрудняет собственно сверку. Данная обработка находит соответствующие расходным накладным счета/заказы, показывает их в форме документа и выводит в печатную форму акта.

2 стартмани

12.05.2017    29456    4    denmax    2    

Редактор движений документа. Сохранение в XML, обмен между базами, замена регистратора.

Обработка документов Универсальные обработки Обмен через XML v8 Абонемент ($m)

Редактор набора записей движений документа. Позволяет сохранить набор записей в XML, в настройки пользователя, прочитать сохраненный XML в другой идентичной базе, заменить регистратор. Можно изменять порядок записей, менять активность, как массово, так и по одной и др. Тонкий клиент, управляемые формы.

1 стартмани

07.09.2016    40621    155    Aphanas    4    

Загрузка Счета покупателя из PDF

Обработка документов Файловые протоколы обмена, FTP Оптовая торговля Оптовая торговля v8 v8::БУ БП3.0 Абонемент ($m)

Обработка позволяет загрузить счет покупателя из pdf-файла в документ Счет на оплату покупателю (Бухгалтерия 3.0)

2 стартмани

23.05.2016    18300    21    John_d    0    

Универсальный ввод на основании (заполнение) документов Промо

Обработка документов v8 v8::УФ КА1 БП2.0 ЗУП2.5 УТ10 Розница УПП1 ERP2 БП3.0 КА2 ЗУП3.x Абонемент ($m)

Обработка позволяет на основании документов одного вида создавать документы другого.

2 стартмани

19.05.2010    37629    124    nika.1007    87    

Управление доставкой розничным покупателям

Обработка документов Розничная торговля Розничная торговля v8 УТ10 Розничная и сетевая торговля (FMCG) Россия УУ Абонемент ($m)

Дополнение для УТ 11.1, оформление доставки для розничного покупателя на основании кассового чека в связке с мягким чеком покупателя.

5 стартмани

10.03.2016    27924    8    Denis_Viktorovich    5    

Ночное восстановление последовательности документов (фоновым заданием) для БП 3.0

Обработка документов v8 v8::БУ БП3.0 Россия Абонемент ($m)

Внешняя обработка служит для восстановления последовательности документов в БП 3.0 за месяц, по расписанию, фоновым заданием на сервере 1С. Подключается как дополнительная обработка в режиме пользователя.

5 стартмани

25.02.2016    35451    84    SmArtist    8    

Простые радости жизни программиста 1С: выбор типа значения

Работа с интерфейсом Практика программирования v8 1cv8.cf Абонемент ($m)

Предлагаемая в работе обработка включает обычную и управляемую формы, которые максимально точно реализуют функциональность системного диалога выбора типа в толстом клиенте обычное приложение (включая оформление диалога). Эти формы имеют дополнительные интерфейсные удобства и могут быть использованы в качестве альтернативных диалогов выбора типа.

1 стартмани

17.02.2016    48839    50    yuraos    17    

Перечисление НДФЛ в бюджет РФ (13%, 30%)

Обработка документов Зарплата Зарплата v8 v8::СПР ЗУП2.5 БУ НУ НДФЛ Абонемент ($m)

Внешняя обработка (табличных частей), предназначенная для корректного заполнения документа "Перечисление НДФЛ в бюджет РФ". Конфигурация: Зарплата и Управление Персоналом, редакция 2.5

1 стартмани

27.01.2016    35007    239    1kashak    23    

Начисление процентов по кредитам и займам для 1С:Бухгалтерии 3.0

Обработка документов Займы, кредит, лизинг Займы, кредит, лизинг v8 БП2.0 Россия БУ Абонемент ($m)

Универсальная обработка по начислению процентов по кредитам и займам для 1С:Бухгалтерии 3.0 без изменения конфигурации

1 стартмани

22.01.2016    65236    165    algora    27    

Пакетная замена номенклатуры с учетом характеристик

Обработка документов Оптовая торговля Учет ТМЦ Оптовая торговля Учет ТМЦ v8 КА1 УТ10 УПП1 УУ Абонемент ($m)

Обработка "Пакетная замена номенклатуры" в Заказе покупателя, Реализации и Поступлении товаров с использованием отбора по значениям характеристик

1 стартмани

22.01.2016    23341    6    trendy    1    

Изменение реквизитов справочников, документов, табличных частей, движений (Обычные и Управляемые формы) Промо

Обработка документов Обработка справочников v8 v8::УФ 1cv8.cf Казахстан Абонемент ($m)

Обработка позволяет редактировать реквизиты справочника, документа, его табличные части и движения.

1 стартмани

15.10.2012    46577    276    Exit_in    42    

Формирование актов сверки взаиморасчётов и групповая печать

Обработка документов Пакетная печать Дебиторская и кредиторская задолженность Дебиторская и кредиторская задолженность v8 БП2.0 БУ Абонемент ($m)

Обработка позволяет сформировать новые акты сверки и распечатать за период разом на принтере

3 стартмани

15.01.2016    34000    38    gortol    4    

Перечисление НДФЛ в бюджет: заполнение НДФЛ по расчетной ведомости для ЗУП 2.5

Обработка документов Зарплата Зарплата v8 ЗУП2.5 Россия БУ НДФЛ Абонемент ($m)

Внешняя обработка для заполнению сумм НДФЛ для перечисления в бюджет по данным расчетной ведомости для 1С ЗУП 2.5

2 стартмани

30.12.2015    21936    71    Snork    4    

Акт сверки с номерами счетов-фактур, начальными остатками по договорам и заполнением по головному контрагенту [Расширение]

Обработка документов Дебиторская и кредиторская задолженность Дебиторская и кредиторская задолженность v8 БП3.0 Россия БУ Абонемент ($m)

Акт сверки взаиморасчетов (БП 3.0): - Вывод начальных и конечных остатков по договорам в печатную форму; - Вывод валютной суммы для договоров в условных единицах; - Заполнение данных счетов-фактур или УПД; - Заполнение данных по головному контрагенту и всем обособленным подразделениям; - Заполнение представителя организации из ответственных лиц; - Факсимильная подпись и печать. Не требует снятия с поддержки и подходит для базовых конфигураций

1 стартмани

15.12.2015    56597    95    mrXoxot    40    

Резервы отпусков для УПП 1.3

Обработка документов Зарплата Зарплата v8 УПП1 Россия БУ Абонемент ($m)

Обработка для создания резерва отпусков в 1С: УПП 1.3

1 стартмани

14.12.2015    26539    39    sarun    5    

Загрузка УПД в Бухгалтерию 3.0

Обработка документов Загрузка и выгрузка в Excel Оптовая торговля Оптовая торговля v8 v8::БУ БП3.0 Россия БУ Абонемент ($m)

Загрузка УПД из Excel в Бухгалтерию предприятия 3.0, с добавлением номенклатуры, ГТД, стран происхождения.

3 стартмани

20.10.2015    22209    17    teyana    12