Конвертация Данных. Нюансы использования конструкции "НеЗамещатьОбъект = Истина" в обработчике события "ПриЗагрузке"

Публикация № 1120243

Управление - Не имеет значения

Конвертация данных пропадают реквизиты не полностью заполняются документы

16
У конвертации данных есть «особенности», которые «пьют кровь» программистов. Эта статья про очередную обнаруженную «особенность».

Клиент – крупный холдинг. Настроен обмен по правилам между двумя базами (УСХП) через ftp ресурс. Пользователи стали жаловаться, что после обмена «затираются» реквизиты документов, а иногда документы «прилетают» не полностью заполненными. В источнике -  все ок. Проблема прослеживалась на платформах с 8.3.10 по 8.3.14

Расследование

Правила обмена уже выучил наизусть. Закономерность в проблеме с реквизитами обнаружить не удалось. Типы документов различные, реквизиты тоже: то склад, то номенклатура в ТЧ, то организация … .  От google никакого толку. Наконец, удалось «поймать» файл выгрузки с косячными документами (пока пользователи сообщат о проблеме, уже пройдет следующая синхронизация).

В правилах обмена у некоторых документов при загрузке стояла проверка, чтобы не портить документы в приемнике:

(1)
<Правило>
     <Код> ПеремещениеТоваров </Код>
     <ПриЗагрузке>
          Если ОбъектНайден Тогда
                ИсходныйОбъект = Объект.Ссылка.ПолучитьОбъект();
                Если ИсходныйОбъект.ОтражатьВБухгалтерскомУчете тогда
                    НеЗамещатьОбъект  =  Истина;
                КонецЕсли;
          КонецЕсли;
     </ ПриЗагрузке >
     <СинхронизироватьПоИдентификатору>true</СинхронизироватьПоИдентификатору>
     <Источник>ДокументСсылка. ПеремещениеТоваров </Источник>
     <Приемник>ДокументСсылка. ПеремещениеТоваров </Приемник>
</Правило>

 

Из справки: «НеЗамещатьОбъект - Булево - Если установить значение Истина, то существующий объект информационной базы не будет изменен.»

Причина проблемы (на примере реквизита «Склад»)

При выгрузке данных в xml используется кеширование, т.е. в первом  выгружаемом объекте (в нашем случае документ «Перемещение товара») склад выгружается полностью:

(2)
<Объект Нпп="27" Тип="ДокументСсылка.ПеремещениеТоваров" ИмяПравила="ПеремещениеТоваров">

…

     <Ссылка Нпп="28" НеСоздаватьЕслиНеНайден="true">
          <Свойство Имя="{КлючПоискаВИБИсточнике}">
               <Значение>{"#",f9727404-36b6-4005-a5b4-77243dc0ff00,419:80bf9457a55a905311e6b55f082221c2}</Значение>
          </Свойство>
          <Свойство Имя="{ИмяТипаВИБИсточнике}">
               <Значение>СправочникСсылка.Склады</Значение>
          </Свойство>
          <Свойство Имя="{УникальныйИдентификатор}">
               <Значение>082221c2-b55f-11e6-80bf-9457a55a9053</Значение>
          </Свойство>
          <Свойство Имя="Код">
               <Значение>00825    </Значение>
          </Свойство>
          <Свойство Имя="Наименование">
               <Значение>Склад бабы Вали</Значение>
          </Свойство>
     </Ссылка>

…

</Объект>

Далее всех последующих объектов выгрузки вместо склада «Склад бабы Вали» подставляется тег <Нпп>28</Нпп> (чтобы не выгружать каждый раз одно и то же и уменьшить объем файла выгрузки).

(3)
<Объект Нпп="266" Тип="ДокументСсылка.КомплектацияНоменклатуры" ИмяПравила="КомплектацияНоменклатуры">

…

     <Свойство Имя="Склад">
          <Нпп>28</Нпп>
     </Свойство>

…

</Объект>

…

И вот возникла ситуация, когда при загрузке в приемник документ «Перемещение Товаров» (именно тот, в котором выгружена ссылка на склад (2)) соответствует условию правила (1) (т.е. в базе уже есть документ с установленным реквизитом БУ и его под страхом смерти нельзя загружать) и выполняется код:

НеЗамещатьОбъект  =  Истина;

Вследствие чего у всех объектов, у которых в xml свойство склад имело значение <Нпп>28</Нпп>, реквизит «Склад» чудесным образом превратился в неопределено («затерся»).

Решение

Правила обмена были переписаны:

(4)
<ПослеЗагрузки>
    Если ОбъектНайден Тогда
         ИсходныйОбъект = Объект.Ссылка.ПолучитьОбъект();
         Если ИсходныйОбъект.ОтражатьВБухгалтерскомУчете Тогда
             Отказ = Истина;
         КонецЕсли;
    КонецЕсли;
</ПослеЗагрузки>

Резюме

 Учитывайте эту особенность при написании правил обмена. Надеюсь, статья сэкономит Ваше время и убережет от ошибок.

16

См. также

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. triviumfan 10 10.09.19 23:31 Сейчас в теме
Хм, а тут не дело в приоритетах?
А вообще - речь про так называемый online-обмен?
5. ivanek 11.09.19 09:09 Сейчас в теме
(1)К сожалению, дело не в приоритетах, проверено.
2. insurgut 197 11.09.19 06:13 Сейчас в теме
Поведение, конечно, не очевидное. У складов в настройках стоит "Использовать быстрый поиск объекта при выгрузке и загрузке"?
4. ivanek 11.09.19 09:06 Сейчас в теме
(2)Нет, ни у одного объекта флаг "Использовать быстрый поиск объекта при выгрузке и загрузке" не установлен.
3. Batman 151 11.09.19 08:04 Сейчас в теме
6. AlX0id 11.09.19 11:15 Сейчас в теме
ИсходныйОбъект = Объект.Ссылка.ПолучитьОбъект();
Если ИсходныйОбъект.ОтражатьВБухгалтерскомУчете Тогда
Отказ = Истина;
КонецЕсли;


Вообще - не очень решение.. В особенности, если документов много. Лучше уж запросом бы сделали получение флага, нежели весь объект вытаскивать.. А в идеале - так и вовсе где-то надо одним запросом вытащить все загружаемые объекты, отраженные в БУ.
10. Vovan1975 14 11.09.19 13:05 Сейчас в теме
(6) да хреновое решение.

Если конфа стандартная 1с то лучше было бы использовать функцию БСП: ОбщегоНазначения.ЗначениеРеквизитаОбъекта(Ссылка, ИмяРеквизита, ВыбратьРазрешенные)
11. ivanek 11.09.19 14:19 Сейчас в теме
(6)Спасибо, согласен, учту замечание.
7. MSK_Step 19 11.09.19 12:39 Сейчас в теме
Не ясна связь между у всех объектов, у которых в xml свойство склад имело значение <Нпп>28</Нпп> и документами. НеЗамещатьОбъект должно относится к конкретному объекту, а получается что влияет на реквизиты других даже объектов. Непонятно. Код загрузки надо смотреть в базе приемнике, как там обрабатывается флажок НеЗамещатьОбъект
8. wowik 602 11.09.19 12:48 Сейчас в теме
12. ivanek 11.09.19 14:21 Сейчас в теме
(8)Забыл в статье указать КД 2.1.8.2
9. Vovan1975 14 11.09.19 12:52 Сейчас в теме
Мой склероз мне подсказывает, что где-то в глубинах КД есть параметр управляющий кэшированием объектов при загрузке(он так и называется "не кэшировать объекты".
Вот его надо было выключить.
Правда побочка была бы в том что при каждом упоминании выгружался бы элемент целиком, что не очень с точки зрения памити (при разборе файлика обмена) да и файлик тоже "вспучивался".
13. Астиг 6 13.09.19 13:51 Сейчас в теме
Спасибо! "При выгрузке данных в xml используется кеширование" - не знал о таком.
Оставьте свое сообщение